dev-python/rosdistro: initial import. ebuild by me.
[gentoo.git] / dev-python / smmap / smmap-0.9.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 python3_{3,4} )
8
9 inherit distutils-r1
10
11 DESCRIPTION="A pure git implementation of a sliding window memory map manager"
12 HOMEPAGE="
13         https://pypi.python.org/pypi/smmap
14         https://github.com/Byron/smmap"
15 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
16
17 LICENSE="BSD"
18 KEYWORDS="amd64 x86"
19 SLOT="0"
20 IUSE="test"
21
22 DEPEND="
23         dev-python/setuptools[${PYTHON_USEDEP}]
24         test? (
25                 dev-python/nose[${PYTHON_USEDEP}]
26                 dev-python/nosexcover[${PYTHON_USEDEP}]
27         )"
28 RDEPEND=""
29
30 python_test() {
31         nosetests || die "tests failed under ${EPYTHON}"
32 }