dev-python/wsgiproxy2: Keyword 0.4.6-r1 ppc, #726188
[gentoo.git] / dev-python / singledispatch / singledispatch-3.4.0.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A library to bring functools.singledispatch from Python 3.4 to Python 2.6-3.3"
11 HOMEPAGE="https://docs.python.org/3/library/functools.html#functools.singledispatch"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PF}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
17 IUSE=""
18
19 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
20 RDEPEND="dev-python/six[${PYTHON_USEDEP}]"