499aae6059da1e32dee98f0824e6a5860472d757
[gentoo.git] / dev-python / simplejson / simplejson-3.15.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
7
8 inherit distutils-r1 flag-o-matic
9
10 DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
11 HOMEPAGE="https://github.com/simplejson/simplejson https://pypi.org/project/simplejson/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="|| ( MIT AFL-2.1 )"
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
17
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19
20 DOCS=( README.rst CHANGES.txt )
21
22 python_compile() {
23         if ! python_is_python3; then
24                 local CFLAGS=${CFLAGS}
25                 append-cflags -fno-strict-aliasing
26         fi
27         distutils-r1_python_compile
28 }
29
30 python_test() {
31         esetup.py test
32 }