dev-lang/swi-prolog: bump 7.3 development version
[gentoo.git] / dev-python / simplegeneric / simplegeneric-0.8.1-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
8
9 inherit distutils-r1
10
11 DESCRIPTION="Simple generic functions for Python"
12 HOMEPAGE="https://pypi.python.org/pypi/simplegeneric"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
14
15 LICENSE="ZPL"
16 SLOT="0"
17 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
18 IUSE=""
19
20 DEPEND="
21         app-arch/unzip
22         dev-python/setuptools[${PYTHON_USEDEP}]"
23 RDEPEND=""
24
25 python_test() {
26         esetup.py test
27 }