0e213daf1600dc3bc577f9654088d830e1a5bdc4
[gentoo.git] / dev-python / simplebayes / simplebayes-1.5.7.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python{2_7,3_6} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="memory-based, optional-persistence naive bayesian text classifier"
10 HOMEPAGE="https://github.com/hickeroar/simplebayes"
11 SRC_URI="https://github.com/hickeroar/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 RDEPEND=""
20 DEPEND="${RDEPEND}
21         dev-python/setuptools[${PYTHON_USEDEP}]
22         test? (
23                 dev-python/mock[${PYTHON_USEDEP}]
24                 dev-python/nose[${PYTHON_USEDEP}]
25         )"
26
27 python_test() {
28         nosetests tests/ || die "test failed under ${EPYTHON}"
29 }