dev-python/backports-unittest-mock: ppc stable (bug 613096).
[gentoo.git] / dev-python / seaborn / seaborn-0.7.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_{4,5}} )
7
8 inherit distutils-r1 virtualx
9
10 DESCRIPTION="Statistical data visualization"
11 HOMEPAGE="http://stanford.edu/~mwaskom/software/seaborn/ https://github.com/mwaskom/seaborn"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="BSD"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18
19 RDEPEND="
20         dev-python/matplotlib[${PYTHON_USEDEP}]
21         dev-python/numpy[${PYTHON_USEDEP}]
22         dev-python/pandas[${PYTHON_USEDEP}]
23         dev-python/patsy[${PYTHON_USEDEP}]
24         dev-python/statsmodels[${PYTHON_USEDEP}]
25         sci-libs/scipy[${PYTHON_USEDEP}]
26 "
27 DEPEND="${RDEPEND}
28         test? (
29                 dev-python/nose[${PYTHON_USEDEP}]
30         )
31 "
32
33 python_test() {
34         cat > matplotlibrc <<- EOF
35         backend : Agg
36         EOF
37         virtx nosetests --verbosity=3
38 }