50b68dde6f2f51a94d6469736347a04bfba56bd1
[gentoo.git] / dev-python / scrypt / scrypt-0.8.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Bindings for the scrypt key derivation function library"
11 HOMEPAGE="https://bitbucket.org/mhallin/py-scrypt/wiki/Home/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD-2"
15 KEYWORDS="amd64 ~arm ~arm64 x86"
16 SLOT="0"
17 IUSE="test doc"
18
19 RDEPEND="dev-libs/openssl:0="
20 DEPEND="${RDEPEND}
21         dev-python/setuptools[${PYTHON_USEDEP}]"
22
23 # dist tarball does not have tests
24 RESTRICT=test
25
26 python_test() {
27         esetup.py test
28 }