Merge remote-tracking branch 'github/pr/108'
[gentoo.git] / dev-python / scimath / scimath-4.1.2-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 )
8
9 inherit distutils-r1 virtualx
10
11 DESCRIPTION="Enthought Tool Suite: Scientific and mathematical tools"
12 HOMEPAGE="http://code.enthought.com/projects/sci_math/ https://pypi.python.org/pypi/scimath"
13 SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0"
17 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
18 IUSE="doc test"
19 DISTUTILS_IN_SOURCE_BUILD=1
20
21 RDEPEND=">=dev-python/traits-4.1[${PYTHON_USEDEP}]
22         >=dev-python/traitsui-4.1[${PYTHON_USEDEP}]
23         sci-libs/scipy[${PYTHON_USEDEP}]"
24 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
25         doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
26         test? (
27                 ${RDEPEND}
28                 media-fonts/font-cursor-misc
29                 media-fonts/font-misc-misc
30                 x11-apps/xhost
31         )"
32
33 python_compile_all() {
34         use doc && emake -C docs html
35 }
36
37 python_test() {
38         # ONE test assumes PYTHONPATH in its own dir!!!
39         PYTHONPATH=build/lib/:build/lib/scimath/interpolate/
40         VIRTUALX_COMMAND="nosetests" virtualmake
41 }
42
43 python_install_all() {
44         use doc && HTML_DOCS=( docs/build/html/. )
45         distutils-r1_python_install_all
46 }