games-board/freedoko: Drop old
[gentoo.git] / dev-python / rtslib / rtslib-3.0_pre4.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="RTSLib Community Edition for target_core_mod/ConfigFS"
11 HOMEPAGE="http://linux-iscsi.org/wiki/targetcli"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 IUSE=""
16
17 if [[ ${PV} == 9999 ]]; then
18         inherit git-r3
19         EGIT_REPO_URI="https://github.com/Datera/${PN}.git"
20         KEYWORDS=""
21 else
22         MY_PV=${PV/_/-}
23         SRC_URI="https://github.com/Datera/${PN}/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
24         S="${WORKDIR}/${PN}-${MY_PV}"
25         KEYWORDS="~amd64"
26 fi
27
28 DEPEND="dev-python/configobj[${PYTHON_USEDEP}]
29         dev-python/ipaddr[${PYTHON_USEDEP}]
30         dev-python/netifaces[${PYTHON_USEDEP}]
31         dev-python/pyparsing[${PYTHON_USEDEP}]
32         !dev-python/rtslib-fb"
33 RDEPEND="${DEPEND}"
34
35 src_install() {
36         distutils-r1_src_install
37         keepdir /var/target/fabric
38         insinto /var/target/fabric
39         doins specs/*.spec
40 }