dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / restructuredtext-lint / restructuredtext-lint-0.12.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Created out of frustration, it sucks to find out your reST is invalid after uploading it."
10 HOMEPAGE="https://pypi.python.org/pypi/restructuredtext_lint"
11
12 MY_P="restructuredtext_lint"
13 SRC_URI="mirror://pypi/${PN:0:1}/${MY_P}/${MY_P}-${PV}.tar.gz"
14 S="${WORKDIR}/${MY_P}-${PV}"
15
16 LICENSE="Unlicense"
17 SLOT="0"
18 KEYWORDS="amd64 ~arm64 x86"
19 IUSE=""
20
21 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
22 RDEPEND="
23         >=dev-python/docutils-0.11[${PYTHON_USEDEP}]
24         <dev-python/docutils-1.0[${PYTHON_USEDEP}]"