dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / dev-python / requests-file / requests-file-1.4.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{3_6,3_7} )
7 inherit distutils-r1
8
9 DESCRIPTION="File transport adapter for Requests"
10 HOMEPAGE="https://pypi.org/project/requests-file/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND="
19         dev-python/setuptools[${PYTHON_USEDEP}]
20 "
21 RDEPEND="
22         dev-python/requests[${PYTHON_USEDEP}]
23         dev-python/six[${PYTHON_USEDEP}]
24 "