dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / repoze-who / repoze-who-2.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="repoze.who is an identification and authentication framework for WSGI"
10 HOMEPAGE="http://www.repoze.org"
11 SRC_URI="mirror://pypi/${PN:0:1}/repoze.who/repoze.who-${PV}.tar.gz"
12 S="${WORKDIR}/repoze.who-${PV}"
13
14 LICENSE="repoze"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm64 x86"
17 IUSE=""
18
19 DEPEND="
20         dev-python/setuptools[${PYTHON_USEDEP}]
21 "
22 RDEPEND="
23         dev-python/webob[${PYTHON_USEDEP}]
24         dev-python/zope-interface[${PYTHON_USEDEP}]
25 "
26
27 python_test() {
28         esetup.py test
29 }