dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / reno / reno-2.7.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Release notes manager, storing release notes in a git repo and building docs"
10 HOMEPAGE="https://pypi.python.org/pypi/reno"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm64 x86"
16 IUSE=""
17
18 CDEPEND=">=dev-python/pbr-1.4[${PYTHON_USEDEP}]"
19 DEPEND="
20         dev-python/setuptools[${PYTHON_USEDEP}]
21         ${CDEPEND}"
22 RDEPEND="
23         ${CDEPEND}
24         >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
25         >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
26         >=dev-python/dulwich-0.15.0[${PYTHON_USEDEP}]"