sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / dev-python / raet / raet-0.6.8-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=(python3_{7,8})
6 inherit distutils-r1
7
8 DESCRIPTION="Reliable Asynchronous Event Transport Protocol"
9 HOMEPAGE="https://github.com/RaetProtocol/raet"
10 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
11
12 LICENSE="Apache-2.0"
13 SLOT="0"
14 KEYWORDS="amd64 ~x86"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND=">=dev-python/six-1.6.1[${PYTHON_USEDEP}]
19         >=dev-python/libnacl-1.4.3[${PYTHON_USEDEP}]
20         >=dev-python/ioflo-2.0[${PYTHON_USEDEP}]"
21 BDEPEND="${RDEPEND}
22         test? (
23                 dev-python/msgpack[${PYTHON_USEDEP}]
24                 dev-python/unittest2[${PYTHON_USEDEP}]
25         )"
26
27 PATCHES=(
28         # This is from https://github.com/RaetProtocol/raet/pull/14/
29         #${FILESDIR}/raet-0.6.8-msgpack-1.0.patch
30 )
31
32 python_prepare_all() {
33         distutils-r1_python_prepare_all
34         sed -i -e "/setuptools_git/d" setup.py || die
35 }
36
37 python_test() {
38         pushd "${BUILD_DIR}"/lib || die
39         ${EPYTHON} ${PN}/test/__init__.py || die "tests failed for ${EPYTHON}"
40         popd || die
41 }