dev-python/rosdistro: initial import. ebuild by me.
[gentoo.git] / dev-python / raet / raet-0.6.3.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=(python{2_7,3_4})
7 inherit distutils-r1
8
9 DESCRIPTION="Reliable Asynchronous Event Transport Protocol"
10 HOMEPAGE="https://github.com/saltstack/raet"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="test"
17
18 RDEPEND=">=dev-python/six-1.6.1[${PYTHON_USEDEP}]
19         >=dev-python/libnacl-1.4.0[${PYTHON_USEDEP}]
20         >=dev-python/ioflo-1.2.1[${PYTHON_USEDEP}]
21         python_targets_python2_7? ( >=dev-python/enum34-1.0.4[$(python_gen_usedep 'python2*')] )"
22 DEPEND="${RDEPEND}
23         dev-python/setuptools[${PYTHON_USEDEP}]
24         test? ( dev-python/unittest2[${PYTHON_USEDEP}] )"
25
26 python_test() {
27         pushd "${BUILD_DIR}"/lib
28         ${EPYTHON} ${PN}/test/__init__.py || die "tests failed for ${EPYTHON}"
29         popd
30 }