dev-python/pygobject: ppc64 stable (bug 611134)
[gentoo.git] / dev-python / pyusb / pyusb-1.0.0_beta2.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python{2_7,3_4} )
6
7 inherit distutils-r1
8
9 MY_P="${P/_beta/b}"
10
11 DESCRIPTION="USB support for Python"
12 HOMEPAGE="http://pyusb.sourceforge.net/"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0"
17 KEYWORDS="~amd64 ~arm ~ppc ~x86"
18 IUSE=""
19
20 ### This version is compatible with both 0.X and 1.X versions of libusb
21 DEPEND="virtual/libusb:=
22         dev-python/setuptools[${PYTHON_USEDEP}]"
23 RDEPEND="${DEPEND}"
24
25 DOCS="README.rst docs/tutorial.rst"
26
27 S="${WORKDIR}/${MY_P}"