dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / pytz / pytz-2017.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
7 PYTHON_REQ_USE="threads(+)"
8
9 inherit distutils-r1
10
11 DESCRIPTION="World timezone definitions for Python"
12 HOMEPAGE="http://pythonhosted.org/pytz/ https://pypi.python.org/pypi/pytz/"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
18 IUSE=""
19
20 RDEPEND="
21         dev-python/setuptools[${PYTHON_USEDEP}]
22         || ( >=sys-libs/timezone-data-2017a sys-libs/glibc[vanilla] )"
23 DEPEND="${RDEPEND}
24         app-arch/unzip"
25
26 PATCHES=(
27         # Use timezone-data zoneinfo.
28         "${FILESDIR}"/2016.6.1-zoneinfo.patch
29         # ...and do not install a copy of it.
30         "${FILESDIR}"/${PN}-2009h-zoneinfo-noinstall.patch
31 )
32
33 python_test() {
34         "${PYTHON}" pytz/tests/test_tzinfo.py -v || die "Tests fail with ${EPYTHON}"
35 }