dev-python/numexpr: Clean old
[gentoo.git] / dev-python / pythondialog / pythondialog-3.3.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=( python{3_3,3_4} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A Python module for making simple text/console-mode user interfaces"
11 HOMEPAGE="http://pythondialog.sourceforge.net/"
12 SRC_URI="mirror://sourceforge/pythondialog//${PV}/python3-${P}.tar.bz2"
13
14 LICENSE="LGPL-2"
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
17 IUSE="doc examples"
18
19 RDEPEND="dev-util/dialog"
20 DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
21
22 python_prepare_all() {
23         sed -e "/^    'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
24         distutils-r1_python_prepare_all
25 }
26
27 python_compile_all() {
28         use doc && emake -C doc html
29 }
30
31 python_install_all() {
32         use examples && local EXAMPLES=( examples/. )
33         use doc && local HTML_DOCS=( doc/_build/html/. )
34
35         distutils-r1_python_install_all
36 }