dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / python_orocos_kdl / python_orocos_kdl-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python{2_7,3_4,3_5} )
6
7 SCM=""
8 if [ "${PV#9999}" != "${PV}" ] ; then
9         SCM="git-r3"
10         EGIT_REPO_URI="https://github.com/orocos/orocos_kinematics_dynamics"
11 fi
12
13 inherit ${SCM} python-r1 cmake-utils
14
15 if [ "${PV#9999}" != "${PV}" ] ; then
16         KEYWORDS=""
17         SRC_URI=""
18 else
19         KEYWORDS="~amd64 ~arm"
20         SRC_URI="https://github.com/orocos/orocos_kinematics_dynamics/archive/v${PV}.tar.gz -> orocos_kinematics_dynamics-${PV}.tar.gz"
21 fi
22
23 DESCRIPTION="Python bindings for KDL"
24 HOMEPAGE="http://www.orocos.org/kdl"
25 LICENSE="LGPL-2.1"
26 SLOT="0"
27 IUSE=""
28 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
29
30 RDEPEND="
31         ${PYTHON_DEPS}
32         sci-libs/orocos_kdl
33         dev-python/sip[${PYTHON_USEDEP}]"
34 DEPEND="${RDEPEND}"
35
36 if [ "${PV#9999}" != "${PV}" ] ; then
37         S=${WORKDIR}/${P}/python_orocos_kdl
38 else
39         S=${WORKDIR}/orocos_kinematics_dynamics-${PV}/python_orocos_kdl
40 fi
41
42 src_configure() {
43         python_foreach_impl cmake-utils_src_configure
44 }
45
46 src_compile() {
47         python_foreach_impl cmake-utils_src_compile
48 }
49
50 src_test() {
51         python_foreach_impl cmake-utils_src_test
52 }
53
54 src_install() {
55         python_foreach_impl cmake-utils_src_install
56
57         # Need to have package.xml in our custom gentoo path
58         insinto /usr/share/ros_packages/${PN}
59         doins "${ED}/usr/share/${PN}/package.xml"
60 }