ac85e75a8aac9ea77730e0186e682d218d603086
[gentoo.git] / dev-python / python-zipstream / python-zipstream-1.1.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_{6,7}} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A zip archive generator"
11 HOMEPAGE="https://github.com/allanlei/python-zipstream"
12 SRC_URI="https://github.com/allanlei/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="GPL-3+"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
21                 test? ( dev-python/nose[${PYTHON_USEDEP}] )"
22
23 python_test() {
24         nosetests -v || die "tests failed under ${EPYTHON}"
25 }