f07efcf9fa5b52856b6477b1e50e965c3b02aae9
[gentoo.git] / dev-python / python-socketio / python-socketio-1.8.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Python implementation of the Socket.IO realtime server."
10 HOMEPAGE="https://${PN}.readthedocs.org/ https://github.com/miguelgrinberg/${PN}/ https://pypi.org/project/${PN}"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="test"
17
18 RDEPEND=">=dev-python/six-1.9.0[${PYTHON_USEDEP}]
19         >=dev-python/python-engineio-1.2.1[${PYTHON_USEDEP}]
20         !dev-python/gevent-socketio"
21 DEPEND="${RDEPEND}
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         test? (
24                 dev-python/mock[${PYTHON_USEDEP}]
25         )"
26
27 # pypi tarball does not contain tests
28 RESTRICT="test"
29
30 src_prepare() {
31         eapply_user
32         distutils-r1_src_prepare
33 }
34
35 python_test() {
36         esetup.py test || die
37 }