dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / python-magic / python-magic-0.4.13.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Access the libmagic file type identification library"
11 HOMEPAGE="https://github.com/ahupp/python-magic"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~hppa ~ia64 ~x86"
17 IUSE=""
18
19 RDEPEND="sys-apps/file[-python]"
20 DEPEND="${DEPEND}
21         dev-python/setuptools[${PYTHON_USEDEP}]"
22
23 python_test() {
24         esetup.py test
25 }