sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / dev-python / python-jose / python-jose-3.1.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_{6,7,8} )
6 DISTUTILS_USE_SETUPTOOLS=bdepend
7 inherit distutils-r1
8
9 DESCRIPTION="A JavaScript Object Signing and Encryption (JOSE) implementation in Python"
10 HOMEPAGE="https://github.com/mpdavis/python-jose https://pypi.org/project/python-jose/"
11 # pypi tarball lacks unit tests
12 #SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
13 SRC_URI="https://github.com/mpdavis/python-jose/archive/${PV}.tar.gz -> ${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20 RDEPEND="
21         dev-python/cryptography[${PYTHON_USEDEP}]
22         dev-python/ecdsa[${PYTHON_USEDEP}]
23         dev-python/pyasn1[${PYTHON_USEDEP}]
24         >=dev-python/pycryptodome-3.3.1[${PYTHON_USEDEP}]
25         dev-python/rsa[${PYTHON_USEDEP}]
26         dev-python/six[${PYTHON_USEDEP}]
27 "
28 BDEPEND="${RDEPEND}"
29
30 distutils_enable_tests pytest
31
32 python_prepare_all() {
33         sed -e 's|'\''pytest-runner'\'',\?||' -i setup.py || die
34         distutils-r1_python_prepare_all
35 }