58e35b3a274b81f01afc661fd44f95c9af835723
[gentoo.git] / dev-python / python-hpilo / python-hpilo-4.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_{5,6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="iLO automation from python or shell"
11 HOMEPAGE="https://pypi.org/project/python-hpilo/"
12 SRC_URI="https://github.com/seveas/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 python_test() {
20         ${EPYTHON} -m unittest discover || die
21 }