f507743f0ffedea2596c5fd44906b4300f0dc652
[gentoo.git] / dev-python / python-gnupg / python-gnupg-0.4.5.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DISTUTILS_USE_SETUPTOOLS="no"
7 PYTHON_COMPAT=( pypy{,3} python2_7 python3_{5,6,7,8} )
8
9 inherit distutils-r1
10
11 DESCRIPTION="A Python wrapper for GnuPG"
12 HOMEPAGE="
13         https://bitbucket.org/vinay.sajip/python-gnupg
14         https://pypi.org/project/python-gnupg/
15 "
16 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
17
18 KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
19 LICENSE="BSD"
20 SLOT="0"
21
22 RDEPEND="app-crypt/gnupg"
23 DEPEND="${RDEPEND}"
24
25 python_test() {
26         # NO_EXTERNAL_TESTS must be enabled,
27         # to disable all tests, which need internet access.
28         NO_EXTERNAL_TESTS=1 "${PYTHON}" test_gnupg.py || die "Tests failed with ${EPYTHON}"
29 }