2746008465fcdaa750c70ca2f797640def1c06a5
[gentoo.git] / dev-python / python-editor / python-editor-1.0.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python{2_7,3_6,3_7} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Programmatically open an editor, capture the result."
10 HOMEPAGE="https://github.com/fmoo/python-editor"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm ~arm64 x86"
16 IUSE=""
17
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19 RDEPEND="dev-python/six[${PYTHON_USEDEP}]"