033c337b29375d03cc508fd797a653187b1fbd38
[gentoo.git] / dev-python / python-ddp / python-ddp-0.1.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="An event driven ddp client"
11 HOMEPAGE="https://pypi.org/project/python-ddp/ https://github.com/hharnisc/python-ddp"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="MIT"
16 KEYWORDS="~amd64"
17 IUSE=""
18
19 RDEPEND="
20         dev-python/pyee[${PYTHON_USEDEP}]
21         dev-python/ws4py[${PYTHON_USEDEP}]
22         dev-python/meteor-ejson[${PYTHON_USEDEP}]
23 "
24 DEPEND="${RDEPEND}"