net-vpn/networkmanager-pptp: update dep for libnm-gtk
[gentoo.git] / dev-python / python-cstruct / python-cstruct-1.7.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_{6,7} )
7
8 inherit distutils-r1
9
10 MY_PN=${PN#python-}
11 MY_P=${MY_PN}-${PV}
12 DESCRIPTION="C-style structs for Python"
13 HOMEPAGE="https://github.com/andreax79/python-cstruct https://pypi.org/project/cstruct/"
14 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19 S=${WORKDIR}/${MY_P}
20
21 DOCS=( README.md )
22
23 python_test() {
24         esetup.py test || die "tests failed under ${EPYTHON}"
25 }