ca8f808077c8244d4f4aeefc0177b2bf1ab08fc7
[gentoo.git] / dev-python / pytest-xprocess / pytest-xprocess-0.12.1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Manage external processes across test runs"
11 HOMEPAGE="https://pypi.org/project/pytest-xprocess/ https://github.com/pytest-dev/pytest-xprocess"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="MIT"
16 KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         dev-python/pytest[${PYTHON_USEDEP}]
22         dev-python/pytest-cache[${PYTHON_USEDEP}]
23         dev-python/psutil[${PYTHON_USEDEP}]
24 "
25 DEPEND="${RDEPEND}"
26
27 python_test() {
28         # Upstream's package mistakenly includes __pycache__ directory that make
29         # tests fail.
30         rm -rf example/__pycache__ || die
31         pytest -v || die
32 }