546988eff4e3498cfbf5a4600fbaf2dd2223b553
[gentoo.git] / dev-python / pytest-virtualenv / pytest-virtualenv-1.7.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DISTUTILS_USE_SETUPTOOLS=rdepend
7 PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
8
9 inherit distutils-r1
10
11 DESCRIPTION="Virtualenv fixture for py.test"
12 HOMEPAGE="https://github.com/man-group/pytest-plugins https://pypi.org/project/pytest-virtualenv/"
13 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~hppa ~mips ~s390 ~sparc ~x86"
18
19 RDEPEND="
20         dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
21         dev-python/pytest-shutil[${PYTHON_USEDEP}]
22         dev-python/pytest[${PYTHON_USEDEP}]
23         dev-python/virtualenv[${PYTHON_USEDEP}]
24 "
25 BDEPEND="
26         test? (
27                 dev-python/mock[${PYTHON_USEDEP}]
28         )
29 "
30
31 distutils_enable_tests setup.py