dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-python / pytest-tempdir / pytest-tempdir-2019.10.12.ebuild
1 # Copyright 2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7 DISTUTILS_USE_SETUPTOOLS=rdepend
8 inherit distutils-r1
9
10 DESCRIPTION="Pytest plugin to support for a predictable and repeatable temporary directory"
11 HOMEPAGE="https://github.com/saltstack/pytest-tempdir"
12 SRC_URI="https://github.com/saltstack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="amd64 ~x86"
17
18 BDEPEND="
19         >=dev-python/pytest-2.8.1[${PYTHON_USEDEP}]
20 "
21
22 distutils_enable_tests pytest
23
24 python_test() {
25         distutils_install_for_testing
26         pytest -vv || die "Tests failed with ${EPYTHON}"
27 }