dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / pytest-isort / pytest-isort-0.1.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="py.test plugin for isort"
11 HOMEPAGE="https://github.com/moccu/${PN} https://pypi.python.org/pypi/${PN}"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
17 IUSE=""
18
19 RDEPEND="
20         >=dev-python/isort-3.9.6[${PYTHON_USEDEP}]
21         >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
22         >=dev-python/pytest-cache-1.0[${PYTHON_USEDEP}]
23 "
24 DEPEND="${RDEPEND}
25         dev-python/setuptools[${PYTHON_USEDEP}]
26 "