99e7b029205e342a9ca69e032b5fc9a50189895e
[gentoo.git] / dev-python / pytest-httpbin / pytest-httpbin-1.0.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Easily test your HTTP library against a local copy of httpbin"
11 HOMEPAGE="https://github.com/kevin1024/pytest-httpbin
12         https://pypi.org/project/pytest-httpbin/"
13 SRC_URI="https://github.com/kevin1024/pytest-httpbin/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
18
19 RDEPEND="
20         dev-python/httpbin[${PYTHON_USEDEP}]
21         dev-python/six[${PYTHON_USEDEP}]
22 "
23 BDEPEND="
24         dev-python/setuptools[${PYTHON_USEDEP}]"
25
26 PATCHES=(
27         "${FILESDIR}"/pytest-httpbin-1.0.0-pypy3-hang.patch
28 )
29
30 distutils_enable_tests pytest