dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / pytest-html / pytest-html-1.14.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Plugin for generating HTML reports for py.test results"
10 HOMEPAGE="https://github.com/pytest-dev/pytest-html/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MPL-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17 # Lots of test failures...
18 RESTRICT="test"
19 RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
20         dev-python/pytest-metadata[${PYTHON_USEDEP}]"
21 DEPEND="${RDEPEND}
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         dev-python/setuptools_scm[${PYTHON_USEDEP}]"
24
25 python_test() {
26         PYTHONPATH=${PWD}${PYTHONPATH:+:}${PYTHONPATH} \
27                 py.test -v -r a testing/test_pytest_html.py || die
28 }