8cb9f4650c325d1f1aed0403ebe6fdac2b5503fc
[gentoo.git] / dev-python / pytest-fixture-config / pytest-fixture-config-1.7.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Virtualenv fixture for py.test"
10 HOMEPAGE="https://github.com/manahl/pytest-plugins https://pypi.org/project/pytest-fixture-config/"
11 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
16
17 RDEPEND="
18         dev-python/pytest[${PYTHON_USEDEP}]
19 "
20 BDEPEND="
21         dev-python/setuptools[${PYTHON_USEDEP}]
22         dev-python/setuptools-git[${PYTHON_USEDEP}]
23         test? ( dev-python/six[${PYTHON_USEDEP}] )
24 "
25
26 distutils_enable_tests pytest