608a680a695335355790b70a7654cb5c6be7d2e9
[gentoo.git] / dev-python / pytest-expect / pytest-expect-1.1.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="py.test plugin that stores test expectations by saving the set of failing tests"
10 HOMEPAGE="https://github.com/gsnedders/pytest-expect/ https://pypi.org/project/pytest-expect/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
16 IUSE=""
17
18 RDEPEND="
19         dev-python/pytest[${PYTHON_USEDEP}]
20         dev-python/u-msgpack[${PYTHON_USEDEP}]"
21
22 BDEPEND="
23         ${RDEPEND}
24         dev-python/setuptools[${PYTHON_USEDEP}]"
25
26 # no tests...
27 RESTRICT="test"