dev-python/numexpr: Clean old
[gentoo.git] / dev-python / pyspf / pyspf-2.0.11.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 PYTHON_COMPAT=( python{2_7,3_3,3_4} )
8 PYTHON_REQ_USE="ipv6?"
9 inherit distutils-r1
10
11 DESCRIPTION="Python implementation of the Sender Policy Framework (SPF) protocol"
12 HOMEPAGE="https://pypi.python.org/pypi/pyspf"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="PSF-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="ipv6 test"
19
20 # >=python-3.3 comes with the built-in ipaddress module
21 RDEPEND="dev-python/authres[${PYTHON_USEDEP}]
22         $(python_gen_cond_dep '>=dev-python/ipaddr-2.1.10[${PYTHON_USEDEP}]' python2_7)
23         $(python_gen_cond_dep 'dev-python/pydns:2[${PYTHON_USEDEP}]' python2_7)
24         $(python_gen_cond_dep 'dev-python/pydns:3[${PYTHON_USEDEP}]' 'python3*')"
25
26 DEPEND="test? ( ${RDEPEND}
27         dev-python/pyyaml[${PYTHON_USEDEP}] )"
28
29 REQUIRED_USE="test? ( ipv6 )"
30
31 python_test() {
32         pushd test &> /dev/null
33         "${PYTHON}" testspf.py || die
34         popd &> /dev/null
35 }