dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / dev-python / pysha3 / pysha3-1.0.2-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6,3_7} )
7 inherit distutils-r1
8
9 DESCRIPTION="SHA-3 (Keccak) for Python 2.7 - 3.5"
10 HOMEPAGE="https://github.com/tiran/pysha3 https://pypi.org/project/pysha3/"
11 SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
12
13 LICENSE="CC0-1.0 PSF-2"
14 SLOT="0"
15 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
16 IUSE=""
17
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19
20 python_prepare_all() {
21         # Remove meaningless AttributeError checks. They don't really test
22         # the implementation but Python implementation behavior, and they
23         # fail with PyPy. Oh yes, and this doesn't affect correctly written
24         # programs.
25         sed -i -e '/AttributeError/d' tests.py || die
26
27         distutils-r1_python_prepare_all
28 }
29
30 python_test() {
31         esetup.py test
32 }