1c60234cc4201dee410bacba1aae78b83c3899f4
[gentoo.git] / dev-python / pyrex / pyrex-0.9.9-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 pypy )
7
8 inherit distutils-r1
9
10 MY_P="Pyrex-${PV}"
11
12 DESCRIPTION="A language for writing Python extension modules"
13 HOMEPAGE="https://www.cosc.canterbury.ac.nz/greg.ewing/python/Pyrex/"
14 SRC_URI="https://www.cosc.canterbury.ac.nz/greg.ewing/python/Pyrex/${MY_P}.tar.gz"
15
16 LICENSE="Apache-2.0"
17 SLOT="0"
18 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x86-solaris"
19 IUSE="examples"
20
21 S="${WORKDIR}/${MY_P}"
22
23 DEPEND=""
24 RDEPEND=""
25 DOCS=( CHANGES.txt README.txt ToDo.txt USAGE.txt )
26
27 python_install_all() {
28         distutils-r1_python_install_all
29
30         dohtml -A c -r Doc/.
31
32         if use examples; then
33                 dodoc -r Demos
34                 docompress -x /usr/share/doc/${PF}/Demos
35         fi
36 }