dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / pyramid / pyramid-1.5.8.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="A small open source Python web framework"
10 HOMEPAGE="http://www.pylonsproject.org/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="repoze"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE="test"
17
18 RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
19         dev-python/chameleon[${PYTHON_USEDEP}]
20         dev-python/mako[${PYTHON_USEDEP}]
21         dev-python/webob[${PYTHON_USEDEP}]
22         dev-python/repoze-lru[${PYTHON_USEDEP}]
23         dev-python/mako[${PYTHON_USEDEP}]
24         dev-python/zope-deprecation[${PYTHON_USEDEP}]
25         dev-python/zope-interface[${PYTHON_USEDEP}]
26         dev-python/translationstring[${PYTHON_USEDEP}]
27         dev-python/pastedeploy[${PYTHON_USEDEP}]
28         dev-python/venusian[${PYTHON_USEDEP}]"
29 DEPEND="${RDEPEND}
30         test? ( dev-python/webtest[${PYTHON_USEDEP}]
31                 $(python_gen_cond_dep \
32                         'dev-python/zope-component[${PYTHON_USEDEP}]' \
33                         'python2*' pypy)
34         )"
35
36 python_test() {
37         esetup.py test
38 }