dev-python/wsgiproxy2: Keyword 0.4.6-r1 ppc, #726188
[gentoo.git] / dev-python / pyquery / pyquery-1.4.1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
7
8 inherit distutils-r1 eutils
9
10 DESCRIPTION="A jQuery-like library for python"
11 HOMEPAGE="https://github.com/gawel/pyquery"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~ppc ppc64 s390 sparc x86"
17 IUSE="test"
18
19 RDEPEND="
20         >=dev-python/lxml-2.1[${PYTHON_USEDEP}]
21         >dev-python/cssselect-0.7.9[${PYTHON_USEDEP}]
22         >=dev-python/webob-1.1.9[${PYTHON_USEDEP}]"
23 DEPEND="
24         test? ( ${RDEPEND}
25                 dev-python/beautifulsoup[${PYTHON_USEDEP}]
26                 dev-python/requests[${PYTHON_USEDEP}]
27                 dev-python/nose[${PYTHON_USEDEP}]
28                 dev-python/webtest[${PYTHON_USEDEP}]
29         )"
30
31 RESTRICT+=" !test? ( test )"
32
33 PATCHES=(
34         "${FILESDIR}/pyquery-1.4.1-network-tests.patch"
35         "${FILESDIR}/pyquery-1.4.1-tests-pypy.patch"
36 )
37
38 python_test() {
39         # The suite, it appears, requires this hard setting of PYTHONPATH!
40         PYTHONPATH=. nosetests || die "Tests fail with ${EPYTHON}"
41 }
42
43 pkg_postinst() {
44         optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup
45 }