dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / pyptlib / pyptlib-0.0.6.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 PYTHON_COMPAT=( python2_7 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Python library for tor's pluggable transport managed-proxy protocol"
10 HOMEPAGE="https://gitweb.torproject.org/pluggable-transports/pyptlib.git"
11 SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm ~mips ~x86"
16 IUSE="doc examples"
17
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19 DOCS=( README.rst TODO )
20
21 python_test() {
22         "${PYTHON}" -m unittest discover || die "tests failed"
23 }
24
25 python_install_all() {
26         use doc && local HTML_DOCS=( doc/html/. )
27         use examples && local EXAMPLES=( examples/. )
28         distutils-r1_python_install_all
29 }