dev-python/absl-py: bump 0.8.1
[gentoo.git] / dev-python / pyprotocols / pyprotocols-1.0_pre2306-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1 flag-o-matic
9
10 MY_PN="PyProtocols"
11 MY_P="${MY_PN}-${PV/_pre/a0dev_r}"
12
13 DESCRIPTION="Extends the PEP 246 adapt function with a new 'declaration API'"
14 HOMEPAGE="http://peak.telecommunity.com/PyProtocols.html https://pypi.org/project/PyProtocols/ \
15         http://svn.eby-sarna.com/PyProtocols/"
16 SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
17
18 LICENSE="|| ( PSF-2 ZPL )"
19 SLOT="0"
20 KEYWORDS="amd64 ~ia64 ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
21 IUSE=""
22
23 RDEPEND=">=dev-python/decoratortools-1.4[${PYTHON_USEDEP}]"
24 DEPEND="${RDEPEND}
25         >=dev-python/pyrex-0.9.9[${PYTHON_USEDEP}]
26         dev-python/setuptools[${PYTHON_USEDEP}]"
27
28 S="${WORKDIR}/${MY_PN}"
29
30 PATCHES=( "${FILESDIR}"/SkipTests.patch )
31 DOCS=( CHANGES.txt README.txt UPGRADING.txt )
32
33 python_prepare_all() {
34         # Rm peripheral & rogue failing tests
35         rm -f src//protocols/tests/{test_twisted.py,test_zope.py} || die
36
37         distutils-r1_python_prepare_all
38 }
39
40 python_configure_all() {
41         append-flags -fno-strict-aliasing
42 }
43
44 python_test() {
45         esetup.py test || die "Tests failed under ${EPYTHON}"
46 }