dev-python/pyotp: Introducing new package
[gentoo.git] / dev-python / pyotp / pyotp-2.2.6.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="PyOTP is a Python library for generating and verifying one-time passwords."
11 HOMEPAGE="https://github.com/pyotp/pyotp https://pypi.org/project/pyotp/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19
20 python_test() {
21         "${EPYTHON}" -m unittest discover -v || die "Testing failed with ${EPYTHON}"
22 }