38f0db95337d71490545c31d445145510f08fa03
[gentoo.git] / dev-python / pyotherside / pyotherside-1.5.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit qmake-utils python-single-r1
9
10 DESCRIPTION="Asynchronous Python 3 Bindings for Qt 5"
11 HOMEPAGE="https://github.com/thp/pyotherside https://thp.io/2011/pyotherside/"
12 SRC_URI="https://github.com/thp/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="ISC"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 REQUIRED_USE=${PYTHON_REQUIRED_USE}
18 # Requires active X display
19 RESTRICT="test"
20
21 RDEPEND="${PYTHON_DEPS}
22         dev-qt/qtcore:5
23         dev-qt/qtdeclarative:5
24         dev-qt/qtgui:5
25         dev-qt/qtsvg:5
26         "
27 DEPEND="${RDEPEND}"
28
29 src_prepare() {
30         sed -i -e "s/qtquicktests//" pyotherside.pro || die
31
32         default
33 }
34
35 src_configure() {
36         eqmake5
37 }
38
39 src_install() {
40         emake install INSTALL_ROOT="${D}"
41 }