dev-lang/swi-prolog: bump 7.3 development version
[gentoo.git] / dev-python / pympler / pympler-0.4.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python{2_7,3_3,3_4} )
8
9 inherit distutils-r1
10
11 MY_PN="Pympler"
12 MY_P="${MY_PN}-${PV}"
13
14 DESCRIPTION="Memory profiling for Python applications"
15 HOMEPAGE="https://code.google.com/p/pympler/ https://pypi.python.org/pypi/Pympler https://github.com/pympler/pympler"
16 SRC_URI="mirror://pypi/P/${MY_PN}/${MY_P}.tar.gz"
17
18 SLOT="0"
19 LICENSE="Apache-2.0"
20 KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
21 IUSE="doc test"
22
23 RDEPEND="dev-python/bottle[${PYTHON_USEDEP}]"
24 DEPEND="test? ( ${RDEPEND} )"
25
26 S="${WORKDIR}"/${MY_P}
27
28 python_prepare_all() {
29         rm pympler/util/bottle.py || die
30         sed \
31                 -e '/import bottle/s:^.*$:import bottle:g' \
32                 -i pympler/web.py || die
33         distutils-r1_python_prepare_all
34 }
35
36 python_test() {
37         # https://github.com/pympler/pympler/issues/22
38         esetup.py try
39 }
40
41 python_install_all() {
42         use doc && local HTML_DOCS=( doc/html/. )
43         distutils-r1_python_install_all
44 }