dev-python/rosdistro: initial import. ebuild by me.
[gentoo.git] / dev-python / pyformance / pyformance-0.3.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=( python{2_7,3_4} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Performance metrics, based on Coda Hale's Yammer metrics"
11 HOMEPAGE="https://pyformance.readthedocs.org/ https://github.com/omergertel/pyformance/ https://pypi.python.org/pypi/pyformance/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
20
21 # https://github.com/omergertel/pyformance/issues/18
22 # https://github.com/omergertel/pyformance/pull/17
23 RESTRICT="test"
24
25 python_test() {
26         PYTHONPATH="${PWD}" python -m unittest \
27                 $(find tests -name 'test_*.py' | LC_ALL=C sort | sed -e 's:/:.:' -e 's:.py$::') || die
28 }