profiles/arch/amd64-fbsd/todo: force pulseaudio on firefox, bug 562412
[gentoo.git] / dev-python / pydvdread / pydvdread-1.0-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=( python2_7 pypy )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A set of Python bindings for the libdvdread library"
11 HOMEPAGE="http://pydvdread.sourceforge.net/"
12 SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.bz2"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
17 IUSE=""
18 RESTRICT="test" # Requires an actual DVD to test.
19
20 DEPEND="media-libs/libdvdread
21                 dev-lang/swig"
22 RDEPEND=""
23
24 PATCHES=( "${FILESDIR}"/${P}-py3k.patch \
25                 "${FILESDIR}"/${P}-api-update.patch )
26
27 python_test() {
28         "${PYTHON}" tests/TestAll.py || die "Tests fail with ${EPYTHON}"
29 }