dev-python/numexpr: Clean old
[gentoo.git] / dev-python / pydispatcher / pydispatcher-2.0.5.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
7
8 inherit distutils-r1 vcs-snapshot
9
10 MY_PN="PyDispatcher"
11
12 DESCRIPTION="Multi-producer-multi-consumer signal dispatching mechanism"
13 HOMEPAGE="http://pydispatcher.sourceforge.net/ https://pypi.python.org/pypi/PyDispatcher"
14 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0"
18 KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
19 IUSE="doc examples"
20
21 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
22 RDEPEND=""
23
24 python_compile_all() {
25         if use doc; then
26                 pushd docs/pydoc/ > /dev/null
27                 "${PYTHON}" builddocs.py || die "Generation of documentation failed"
28                 popd > /dev/null
29         fi
30 }
31
32 python_test() {
33         "${PYTHON}" -m unittest discover
34 }
35
36 python_install_all() {
37         use doc && local HTML_DOCS=( docs/pydoc/. )
38         use examples && local EXAMPLES=( examples/. )
39         distutils-r1_python_install_all
40 }