dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / pycipher / pycipher-0.2-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_4,3_5} )
7
8 inherit python-r1
9
10 DESCRIPTION="A Python module that implements several well-known classical cipher algorithms"
11 HOMEPAGE="http://pycipher.sourceforge.net"
12 SRC_URI="mirror://sourceforge/${PN}/${P}.py"
13
14 LICENSE="BSD-2"
15 SLOT="0"
16 KEYWORDS="~x86 ~amd64"
17 IUSE=""
18 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
19
20 RDEPEND="${PYTHON_DEPS}"
21 DEPEND="${RDEPEND}"
22
23 src_unpack() {
24         mkdir "${S}" || die
25         cp "${DISTDIR}/${A}" "${S}/${PN}.py" || die
26 }
27
28 src_install() {
29         python_foreach_impl python_domodule ${PN}.py
30 }